Sun Moon Planets
This program is provided free for use by anyone with an interest in astronomy. There
are no warranties on this program. The calculated data is reasonably accurate to the
best of my knowledge.
I wish to acknowledge Jean Meeus and his book Astronomical Algorithms, PJ Naughter
for his coding insights, also, Oliver Montenbruck and Thomas Pfleger's book Astronomy
on the Personal Computer.

The opening screen of the program displays the daily motions of the planets as they
orbit around the Sun and notifies the user of any events or phenomena that may be
happening on that day. The program also provides a set of informative tables regarding
the Sun, Moon, and planets.

Sun Tables include:
• Sun data such as its distance, equatorial , ecliptic and, horizontal coordinates.
• Sun rise, transit and set times.
• Sun ephemeris.
• Solar eclipse tables.
Moon Tables include:
• Moon data such as its distance, equatorial , ecliptic and, horizontal coordinates.
• Moon rise, transit and set times.
• Moon ephemeris.
• Daily Moon phase angles.
• Quarterly phases of the Moon.
• Lunar eclipse tables.
Planet Tables include (for each major planet):
• Planet data such as its distance, equatorial , ecliptic and, horizontal coordinates.
• Planet rise, transit and set times.
• Planet ephemerides.
• Planetary phenomena.
• Earth equinox and solstice dates.

Each of the tables allow you to enter a date (between 1900 and 2100) to determine a
variety of information about the Sun, Moon or any of the major planets. You may also
copy any selected data and paste it into a text file which can be used as your own
personal observing guide.
The program also provides a set of tools to change the date or to animate the motion
of the planets as they orbit the Sun.

Menu Items
File

The File menu item allows you to create or open a standard ascii text file so that you
can copy data from the tables, edit them, add notes, save it or print it out.

Date & Location

The Date menu item allows you to Select a Date between 1900 and 2100. This date
applies only to the opening screen showing the position of the planets. It does not
apply to any of the tables.
The Location menu item allows you to Set Location. This is typically your home
location. The selected location is applied to several of the tables to provide you with
local times of the events (such as rise, transit and set times).

View

The View menu item allows you to turn on or off some of the features such as the
Status Line and ToolBar.

You can also select Planets for View; it gives you a set of check boxes to choose which
planets and their orbits you wish to show on the main screen. You may also turn on or
off the planet names and any associated date including points of perihelion or
aphelion.

The View menu also allows you to change the main screen to show the Earth and
Moon as they orbit the Sun (Earth Moon Sun View). This is a handy feature when
studying lunar and solar eclipses or just phases of the Moon.
There is also an Events Calendar. Just select the year and month to see a listing of any
events for the month.

The next item in the View menu is the Ecliptic View.
This view shows the path of the Sun, Moon and planets as they follow the ecliptic from
0 to 24 hours Right Ascension.

The last item in the View menu is Planet Orbital Elements. This provides a listing of the
orbital elements for each planet (a, e, i, N, p, L). These orbital elements are used to
determine a planet's position at any time.

Tables

The Tables menu item contains: Sun Tables, Moon Tables and Planet Tables.
As described above, these tables provide a great deal of information regarding the Sun,
Moon and planets.
You may enter a date and location as needed to calculate the type of data as listed in
the tabs along the top row of the dialog box.

Conversions
This menu item allows you to make conversions as follows:
• Date-Time to/from Julian Day
• Greenwich Date-Time to Sidereal
• DMS to/from Degrees

Orbital Tools

This menu item provides tools such as Orbital Speed that allows you to animate the
main screen so that you can see the planets orbiting the Sun. You can also see the
Moon orbiting Earth as both orbit the Sun.

There is also a tool for Incremental Motion so that you can move forward or reverse in
time by a day, month. 3 months, 6 months or a year.

An Orbit Scale (Zoom) tool for scaling the main screen larger or smaller. This allows
you to see the orbital path of Neptune far out in the solar system.

An Offset from Center tool allows you to shift the center of the solar system around
the screen to improve the view if necessary.

Help

The Help menu item provides various information regarding The Orbits plus a set of
Notes and Illustrations that explain some of the terminology.

Examples of How to Use this Program
1) The opening screen of the program shows the position of the planets at the present
date (0 hours UT). Use the menu item Select a Date to change the year to the next year
or the previous year. Again note the position of the planets, particularly that Earth is
still in the same position and Mars has moved approximately halfway around its orbital
path. Try advancing the month and days and note the changing position of the planets.
Approximately how long did it take for Mercury and Venus to make a complete orbit
around the Sun?
Definitions:
Synodic Period - Time between two successive identical positions of a planet as seen
from Earth.
Sidereal Period - True orbital period of a planet, the time required for the planet to
complete one full orbit of the Sun.

2) On the opening screen adjust the vertical slider (right-hand side of screen) to about
the mid-position. Note all the planets appear to be orbiting in a flat plane. This plane is
called the Ecliptic. Click on View and select Ecliptic View. In the dialog box click the
check box to show the planets. Note how the planets are all very close to the blue line
(Ecliptic). The blue line gives the RA and Dec of any planet, Moon or the Sun at any
date. Inside the dialog box adjust the date by increasing the month and clicking the Go
button. Note the motions along the Ecliptic of the Sun, Moon and planets.

Definition:
Ecliptic - an imaginary line on the sky that marks the apparent path the Sun follows over the
course of one year.

3) Click View and select Earth Moon Sun View. Note the position of the Moon with
respect to Earth. Click on Select a Date again and advance the days one at a time to 7
days. How far did the Moon go around the Earth? Advance the month by one month.
How far did the Earth go around the Sun? How far did the Moon go around the Earth?
4) Reset the screen to show planets orbiting the Sun. Set the date to March 20 (or
March 21 - depending on the year).
Click menu item Tables and select Sun Tables. Click the tab Sun Ephemeris and set the
date to March 20. In the first row of data (Sun Ephemeris tab) take note of the Date, RA
and Dec. The RA of the Sun should be close to 0 (or 24) hours. Look at the relative
position of the Sun with respect to the Earth. The Earth should be directly in-line with
the Sun and in opposition to the First Point of Aries. Next, find the date when RA of the
Sun is equal to 12 hours (in September). Set that date for the main screen and note
that Earth will be in conjunction with the First Point of Aries and in-line with the Sun. At
RA of the Sun equal to 24 hours, Earth be back where it was on March 20.
Definitions:
Right Ascension (RA) - Right Ascension is measured from the Sun at the March equinox
( Sun is at the First Point of Aries). This is where the Sun crosses the celestial equator
from south to north at the March equinox (also called vernal Equinox).
Declination (Dec) - the angular distance of a point north or south of the celestial
equator.

5) Click menu item Tables and select Planet Tables. In the dialog box click the tab Earth
Equinox / Solstice Dates. Note the date of the June (Summer) Solstice. Click the screen
menu item Date and change the month and day to the date shown in the Planet dialog
box. On the main screen you should see the relative position of the Sun and Earth at
the Summer Solstice (compared to the direction of the First Point of Aries). Repeat this
procedure using the dates in the dialog box to see the position of Earth with respect to
the Sun at the Winter Solstice in December.

6) Click View and select Earth Moon Sun View. Click menu item Tables and select
Moon Tables. In the dialog box click the tab Quarterly Phases of the Moon. In the
listing find the date of the next New Moon. Click the menu item Date and change the
year, month and day to the date shown in the dialog box. Then close the dialog boxes
and observe the position of the Earth, Moon and Sun on the screen. The Moon should
be in-line (conjunction) with the Sun. Keep in mind that the positions of the Earth and
Moon were calculated at 0 hours UT but the time of the New Moon may be a few
hours more or less than that.
Repeat this procedure to view the position of the Moon at First Quarter, Full Moon and
Last Quarter.
You can also observe this using the Ecliptic View dialog box. By changing the dates you
can observe the position of the Moon in relation to the Sun.

7) Click View and select Earth Moon Sun View. Click menu item Tables and select Sun
Tables. In the dialog box click the tab Solar Eclipse Tables. In the listing find the date of
the next Total Solar Eclipse. Click the menu item Date and change the year, month and
day to the date shown in the dialog box. Then close the dialog boxes and observe the
position of the Earth, Moon and Sun on the screen. The Moon should be in-line
between the Sun and Earth. You may also note in the green text on the top left side of
the screen that it indicates a New Moon and the Solar Eclipse at a given time UT. Note
that on the screen the Moon may not be completely in position since the position of
the Earth and Moon were calculated at 0 hours UT and the solar eclipse probably
occurs several hours later (solar eclipses don't occur at midnight).

8) Click View and select Earth Moon Sun View. Click menu item Tables and select
Moon Tables. In the dialog box click the tab Lunar Eclipse Tables. In the listing find the
date of the next Total Lunar Eclipse. Click the menu item Date and change the year,
month and day to the date shown in the dialog box. Then close the dialog boxes and
observe the position of the Earth, Moon and Sun on the screen. The Moon should be in
opposition to the Sun. You may also note in the green text on the top left side of the
screen that it indicates a Full Moon and the Total Lunar Eclipse at a given time UT. Note
that on the screen the Moon may not be completely in position since the position of
the Earth and Moon were calculated at 0 hours UT and the lunar eclipse may occur a
few hours before or after 0 hours UT (midnight).

9) Click View and de-select Earth Moon Sun View. You should be showing the main
screen with all the planets. Click menu item Tables and select Planet Tables. In the
dialog box click the tab Planetary Phenomena. From the combo box select the planet
Mercury and click the Go button. In the listing find the date of the next Superior
Conjunction. Click the menu item Date and change the year, month and day to the date
shown in the dialog box. Then close the dialog boxes and observe the position of the
Earth, Mercury and the Sun. To improve the view you might move the vertical slider to
the bottom and then use the Scale Tool to enlarge the orbits.

10) On the main screen with all the planets, click menu item Tables and select Planet
Tables. In the dialog box click the tab Planetary Phenomena. From the combo box
select the planet Mars and click the Go button. In the listing find the date of the next
Opposition. Click the menu item Date and change the year, month and day to the date
shown in the dialog box. Then close the dialog boxes and observe the position of the
Earth, Mars and the Sun. To improve the view you might move the vertical slider to the
bottom and then use the Scale Tool to enlarge the orbits. Note the green text on the
top left side of the screen - Mars at Opposition.
There are many other features in this program for you to discover. Be careful to set the
dates on the main screen to the dates obtained in the Sun, Moon, and Planet dialog
boxes.
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